Possible Strong Parameters Bypass in ActionPack
CVE-2020-8164GHSA-8727-m6gj-mc37
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (actionpack 6.0.3.1, 5.2.4.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems actionpack
- Affected
- >= 5.0.0, <= 5.2.4.2>= 6.0.0, <= 6.0.3
- Fixed in
- 6.0.3.1, 5.2.4.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8727-m6gj-mc37 lists affected ranges: RubyGems actionpack >=5.0.0 =6.0.0 <=6.0.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2020-8164: 4.89% estimated exploitation activity in the next 30 days; percentile 92.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
There is a strong parameters bypass vector in ActionPack. Versions Affected: rails <= 6.0.3 Not affected: rails < 5.0.0 Fixed Versions: rails = 5.2.4.3, rails = 6.0.3.1 Impact ------ In some cases user supplied information can be inadvertently leaked from Strong Parameters. Specifically the return value of each, or eachvalue, or eachpair will return the underlying "untrusted" hash of data that was read from the parameters. Applications that use this return value may be inadvertently use untrusted user input. Impacted code will look something like this: Note the mistaken use of each in the cleanupparams method in the above example. Workarounds ----------- Do not use the return values of each, eachvalue, or eachpair in your application.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8727-m6gj-mc37
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-8164 Advisory: Possible Strong Parameters Bypass in ActionPack IDs: CVE-2020-8164, GHSA-8727-m6gj-mc37 Record: https://patchnext.com/advisories/cve-2020-8164 (revision 1, source checked 26 Oct 2026, 15:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: actionpack 6.0.3.1, 5.2.4.3. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems actionpack: affected >= 5.0.0, <= 5.2.4.2; >= 6.0.0, <= 6.0.3; fixed in 6.0.3.1, 5.2.4.3 ## Suggested inspection (read-only) - RubyGems actionpack: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on actionpack. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8727-m6gj-mc37 (GitHub-reviewed advisory GHSA-8727-m6gj-mc37 lists affected ranges: RubyGems actionpack >=5.0.0 =6.0.0 <=6.0.3) Commands are suggestions: review each one before running it.
Loading voting…