Circumvention of file size limits in ActiveStorage
CVE-2020-8162GHSA-m42x-37p3-fv5w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (activestorage 6.0.3.1, 5.2.4.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems activestorage
- Affected
- >= 5.0.0, <= 5.2.4.2>= 6.0.0, <= 6.0.3
- Fixed in
- 6.0.3.1, 5.2.4.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m42x-37p3-fv5w lists affected ranges: RubyGems activestorage >=5.0.0 =6.0.0 <=6.0.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2020-8162: 3.03% estimated exploitation activity in the next 30 days; percentile 87.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
There is a vulnerability in ActiveStorage's S3 adapter that allows the Content-Length of a direct file upload to be modified by an end user. Versions Affected: rails < 5.2.4.2, rails < 6.0.3.1 Not affected: Applications that do not use the direct upload functionality of the ActiveStorage S3 adapter. Fixed Versions: rails = 5.2.4.3, rails = 6.0.3.1 Impact ------ Utilizing this vulnerability, an attacker can control the Content-Length of an S3 direct upload URL without receiving a new signature from the server. This could be used to bypass controls in place on the server to limit upload size. Workarounds ----------- This is a low-severity security issue. As such, no workaround is necessarily until such time as the application can be upgraded.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-m42x-37p3-fv5w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-8162 Advisory: Circumvention of file size limits in ActiveStorage IDs: CVE-2020-8162, GHSA-m42x-37p3-fv5w Record: https://patchnext.com/advisories/cve-2020-8162 (revision 1, source checked 26 Oct 2026, 15:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: activestorage 6.0.3.1, 5.2.4.3. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems activestorage: affected >= 5.0.0, <= 5.2.4.2; >= 6.0.0, <= 6.0.3; fixed in 6.0.3.1, 5.2.4.3 ## Suggested inspection (read-only) - RubyGems activestorage: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on activestorage. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-m42x-37p3-fv5w (GitHub-reviewed advisory GHSA-m42x-37p3-fv5w lists affected ranges: RubyGems activestorage >=5.0.0 =6.0.0 <=6.0.3) Commands are suggestions: review each one before running it.
Loading voting…