Improper Control of Generation of Code in doT
CVE-2020-8141GHSA-297x-8xj4-vcxv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (dot 1.1.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm dot
- Affected
- <= 1.1.2
- Fixed in
- 1.1.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-297x-8xj4-vcxv lists affected ranges: npm dot >=0 <1.1.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-297x-8xj4-vcxv lists affected ranges: npm dot >=0 <=1.1.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2020-8141: 2.20% estimated exploitation activity in the next 30 days; percentile 82.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The dot package v1.1.2 uses Function() to compile templates. This can be exploited by the attacker if they can control the given template or if they can control the value set on Object.prototype.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-297x-8xj4-vcxv
- Revision 1 · created ·
Published from osv record GHSA-297x-8xj4-vcxv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-8141 Advisory: Improper Control of Generation of Code in doT IDs: CVE-2020-8141, GHSA-297x-8xj4-vcxv Record: https://patchnext.com/advisories/cve-2020-8141 (revision 2, source checked 26 Oct 2026, 12:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: dot 1.1.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm dot: affected <= 1.1.2; fixed in 1.1.3 ## Suggested inspection (read-only) - `npm ls dot --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on dot. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-297x-8xj4-vcxv (OSV record GHSA-297x-8xj4-vcxv lists affected ranges: npm dot >=0 <1.1.3 (fixed)) - Verified: https://github.com/advisories/GHSA-297x-8xj4-vcxv (GitHub-reviewed advisory GHSA-297x-8xj4-vcxv lists affected ranges: npm dot >=0 <=1.1.2) Commands are suggestions: review each one before running it.
Loading voting…