Skip to content

← Actionable
Medium, CVSS 6.4

OS Command Injection in Rake

CVE-2020-8130GHSA-jppv-gw3r-w3q8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (rake 12.3.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems rake

    Affected
    <= 12.3.2
    Fixed in
    12.3.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.4 · CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2020-8130: 1.36% estimated exploitation activity in the next 30 days; percentile 71.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

There is an OS command injection vulnerability in Ruby Rake before 12.3.3 in Rake::FileList when supplying a filename that begins with the pipe character |.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jppv-gw3r-w3q8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-8130

Advisory: OS Command Injection in Rake
IDs: CVE-2020-8130, GHSA-jppv-gw3r-w3q8
Record: https://patchnext.com/advisories/cve-2020-8130 (revision 1, source checked 26 Oct 2026, 15:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: rake 12.3.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems rake: affected <= 12.3.2; fixed in 12.3.3

## Suggested inspection (read-only)
- RubyGems rake: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on rake.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jppv-gw3r-w3q8 (GitHub-reviewed advisory GHSA-jppv-gw3r-w3q8 lists affected ranges: RubyGems rake >=0 <=12.3.2)

Commands are suggestions: review each one before running it.

Loading voting…