dot-prop Prototype Pollution vulnerability
CVE-2020-8116GHSA-ff7x-qrg7-qggm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (dot-prop 5.1.1, 4.2.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm dot-prop
- Affected
- < 4.2.1>= 5.0.0, < 5.1.1
- Fixed in
- 4.2.1, 5.1.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-ff7x-qrg7-qggm lists affected ranges: npm dot-prop >=0 =5.0.0 <5.1.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-ff7x-qrg7-qggm lists affected ranges: npm dot-prop >=0 =5.0.0 <5.1.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- EPSS
- CVE-2020-8116: 3.08% estimated exploitation activity in the next 30 days; percentile 87.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Prototype pollution vulnerability in dot-prop npm package versions before 4.2.1 and versions 5.x before 5.1.1 allows an attacker to add arbitrary properties to JavaScript language constructs such as objects.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-ff7x-qrg7-qggm
- Revision 1 · created ·
Published from osv record GHSA-ff7x-qrg7-qggm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-8116 Advisory: dot-prop Prototype Pollution vulnerability IDs: CVE-2020-8116, GHSA-ff7x-qrg7-qggm Record: https://patchnext.com/advisories/cve-2020-8116 (revision 2, source checked 26 Oct 2026, 12:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: dot-prop 5.1.1, 4.2.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm dot-prop: affected < 4.2.1; >= 5.0.0, < 5.1.1; fixed in 4.2.1, 5.1.1 ## Suggested inspection (read-only) - `npm ls dot-prop --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on dot-prop. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-ff7x-qrg7-qggm (OSV record GHSA-ff7x-qrg7-qggm lists affected ranges: npm dot-prop >=0 =5.0.0 <5.1.1 (fixed)) - Verified: https://github.com/advisories/GHSA-ff7x-qrg7-qggm (GitHub-reviewed advisory GHSA-ff7x-qrg7-qggm lists affected ranges: npm dot-prop >=0 =5.0.0 <5.1.1) Commands are suggestions: review each one before running it.
Loading voting…