Skip to content

← Actionable
Medium, CVSS 6.5

Improper Certificate Validation in Puppet

CVE-2020-7942GHSA-gqvf-892r-vjm5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (puppet 6.13.0, 5.5.19), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems puppet

    Affected
    >= 6.0.0, < 6.13.0< 5.5.19
    Fixed in
    5.5.19, 6.13.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2020-7942: 0.80% estimated exploitation activity in the next 30 days; percentile 56.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Previously, Puppet operated on the model that a node with a valid certificate was entitled to all information in the system and that a compromised certificate allowed access to everything in the infrastructure. When a node's catalog falls back to the default node, the catalog can be retrieved for a different node by modifying facts for the Puppet run. This issue can be mitigated by setting stricthostnamechecking = true in puppet.conf on your Puppet master. Puppet 6.13.0 changes the default behavior for stricthostnamechecking from false to true. It is recommended that Puppet Open Source and Puppet Enterprise users that are not upgrading still set stricthostnamechecking to true to ensure secure behavior.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gqvf-892r-vjm5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-7942

Advisory: Improper Certificate Validation in Puppet
IDs: CVE-2020-7942, GHSA-gqvf-892r-vjm5
Record: https://patchnext.com/advisories/cve-2020-7942 (revision 1, source checked 26 Oct 2026, 15:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: puppet 6.13.0, 5.5.19. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems puppet: affected >= 6.0.0, < 6.13.0; < 5.5.19; fixed in 5.5.19, 6.13.0

## Suggested inspection (read-only)
- RubyGems puppet: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on puppet.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gqvf-892r-vjm5 (GitHub-reviewed advisory GHSA-gqvf-892r-vjm5 lists affected ranges: RubyGems puppet >=6.0.0 =0 <5.5.19)

Commands are suggestions: review each one before running it.

Loading voting…