Skip to content

← Actionable
High, CVSS 8.7amended

Plone Privilege Escallation

CVE-2020-7938GHSA-cjg3-q24h-9qwf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (plone-restapi 6.2.1; plone 5.2.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI plone-restapi

    Affected
    < 6.2.1
    Fixed in
    6.2.1
  • PyPI plone

    Affected
    >= 5.2.0, < 5.2.2
    Fixed in
    5.2.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2020-7938: 1.47% estimated exploitation activity in the next 30 days; percentile 73.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

plone.restapi in Plone 5.2.0 through 5.2.1 allows users with a certain privilege level to escalate their privileges up to the highest level.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-cjg3-q24h-9qwf

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-cjg3-q24h-9qwf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-7938

Advisory: Plone Privilege Escallation
IDs: CVE-2020-7938, GHSA-cjg3-q24h-9qwf
Record: https://patchnext.com/advisories/cve-2020-7938 (revision 3, source checked 26 Oct 2026, 13:22 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: plone-restapi 6.2.1; plone 5.2.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI plone-restapi: affected < 6.2.1; fixed in 6.2.1
- PyPI plone: affected >= 5.2.0, < 5.2.2; fixed in 5.2.2

## Suggested inspection (read-only)
- `python -m pip show plone-restapi`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show plone`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on plone-restapi, plone.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-cjg3-q24h-9qwf (OSV record GHSA-cjg3-q24h-9qwf lists affected ranges: PyPI plone-restapi >=0 =5.2.0 <5.2.2 (fixed))
- Verified: https://github.com/advisories/GHSA-cjg3-q24h-9qwf (GitHub-reviewed advisory GHSA-cjg3-q24h-9qwf lists affected ranges: PyPI plone-restapi >=0 =5.2.0 <5.2.2)

Commands are suggestions: review each one before running it.

Loading voting…