Helm uses crypto package vulnerable to panic from malformed X.509 certificate
CVE-2020-7919GHSA-cjjc-xp8v-855w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (helm.sh/helm/v3 3.1.0; golang.org/x/crypto 0.0.0-20200124225646-8b5121be2f68; github.com/helm/helm 2.16.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 3.0.0, < 3.1.0
- Fixed in
- 3.1.0
- Affected
- < 0.0.0-20200124225646-8b5121be2f68
- Fixed in
- 0.0.0-20200124225646-8b5121be2f68
- Affected
- >= 2.0.0, < 2.16.8
- Fixed in
- 2.16.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cjjc-xp8v-855w lists affected ranges: Go github.com/helm/helm >=2.0.0 =0 =3.0.0 <3.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2020-7919: 2.65% estimated exploitation activity in the next 30 days; percentile 85.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The Helm core maintainers have identified a high severity security vulnerability in Go's crypto package affecting all versions prior to Helm 2.16.8 and Helm 3.1.0. Thanks to @ravin9249 for identifying the vulnerability. Impact Go before 1.12.16 and 1.13.x before 1.13.7 (and the crypto/cryptobyte package before 0.0.0-20200124225646-8b5121be2f68 for Go) allows attacks on clients resulting in a panic via a malformed X.509 certificate. This may allow a remote attacker to cause a denial of service. Patches A patch to compile Helm against Go 1.14.4 has been provided for Helm 2 and is available in Helm 2.16.8. Helm 3.1.0 and newer are compiled against Go 1.13.7+. Workarounds No workaround is available. Users are urged to upgrade. References - https://nvd.nist.gov/vuln/detail/CVE-2020-7919 - https://github.com/helm/helm/pull/8288 For more information If you have any questions or comments about this advisory: Open an issue in the Helm repository For security-specific issues, email us at…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-cjjc-xp8v-855w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-7919 Advisory: Helm uses crypto package vulnerable to panic from malformed X.509 certificate IDs: CVE-2020-7919, GHSA-cjjc-xp8v-855w Record: https://patchnext.com/advisories/cve-2020-7919 (revision 1, source checked 26 Oct 2026, 15:04 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: helm.sh/helm/v3 3.1.0; golang.org/x/crypto 0.0.0-20200124225646-8b5121be2f68; github.com/helm/helm 2.16.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Go helm.sh/helm/v3: affected >= 3.0.0, < 3.1.0; fixed in 3.1.0 - Go golang.org/x/crypto: affected < 0.0.0-20200124225646-8b5121be2f68; fixed in 0.0.0-20200124225646-8b5121be2f68 - Go github.com/helm/helm: affected >= 2.0.0, < 2.16.8; fixed in 2.16.8 ## Suggested inspection (read-only) - Go helm.sh/helm/v3: check the installed version with your package manager. - Go golang.org/x/crypto: check the installed version with your package manager. - Go github.com/helm/helm: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on helm.sh/helm/v3, golang.org/x/crypto, github.com/helm/helm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-cjjc-xp8v-855w (GitHub-reviewed advisory GHSA-cjjc-xp8v-855w lists affected ranges: Go github.com/helm/helm >=2.0.0 =0 =3.0.0 <3.1.0) Commands are suggestions: review each one before running it.
Loading voting…