Cross-site scripting in phpoffice/phpspreadsheet
CVE-2020-7776GHSA-4mqv-gcr3-pff9
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist phpoffice/phpexcel
- Affected
- <= 1.8.2
- Fixed in
- no fixed version recorded
Packagist phpoffice/phpspreadsheet
- Affected
- < 1.16.0
- Fixed in
- 1.16.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4mqv-gcr3-pff9 lists affected ranges: Packagist phpoffice/phpspreadsheet >=0 =0 <=1.8.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- EPSS
- CVE-2020-7776: 1.32% estimated exploitation activity in the next 30 days; percentile 70.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
This affects the package phpoffice/phpspreadsheet. The library is vulnerable to XSS when creating an html output from an excel file by adding a comment on any cell. The root cause of this issue is within the HTML writer where user comments are concatenated as part of link and this is returned as HTML.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4mqv-gcr3-pff9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-7776 Advisory: Cross-site scripting in phpoffice/phpspreadsheet IDs: CVE-2020-7776, GHSA-4mqv-gcr3-pff9 Record: https://patchnext.com/advisories/cve-2020-7776 (revision 1, source checked 26 Oct 2026, 14:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: phpoffice/phpspreadsheet 1.16.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist phpoffice/phpexcel: affected <= 1.8.2 - Packagist phpoffice/phpspreadsheet: affected < 1.16.0; fixed in 1.16.0 ## Suggested inspection (read-only) - Packagist phpoffice/phpexcel: check the installed version with your package manager. - Packagist phpoffice/phpspreadsheet: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on phpoffice/phpexcel, phpoffice/phpspreadsheet. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4mqv-gcr3-pff9 (GitHub-reviewed advisory GHSA-4mqv-gcr3-pff9 lists affected ranges: Packagist phpoffice/phpspreadsheet >=0 =0 <=1.8.2) Commands are suggestions: review each one before running it.
Loading voting…