Regular Expression Denial of Service in npm-user-validate
CVE-2020-7754GHSA-pw54-mh39-w3hc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (npm-user-validate 1.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- <= 1.0.0
- Fixed in
- 1.0.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pw54-mh39-w3hc lists affected ranges: npm npm-user-validate >=0 <1.0.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xgh6-85xh-479p lists affected ranges: npm npm-user-validate >=0 <1.0.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xgh6-85xh-479p lists affected ranges: npm npm-user-validate >=0 <=1.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2020-7754: 3.48% estimated exploitation activity in the next 30 days; percentile 89.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
npm-user-validate before version 1.0.1 is vulnerable to a Regular Expression Denial of Service (REDos). The regex that validates user emails took exponentially longer to process long input strings beginning with @ characters. Impact The issue affects the email function. If you use this function to process arbitrary user input with no character limit the application may be susceptible to Denial of Service. Patches The issue is patched in version 1.0.1 by improving the regular expression used and also enforcing a 254 character limit. Workarounds Restrict the character length to a reasonable degree before passing a value to .emal(); Also, consider doing a more rigorous sanitizing/validation beforehand.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-xgh6-85xh-479p
- Revision 2 · amended ·
Amended from osv record GHSA-xgh6-85xh-479p
- Revision 1 · created ·
Published from osv record GHSA-pw54-mh39-w3hc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-7754 Advisory: Regular Expression Denial of Service in npm-user-validate IDs: CVE-2020-7754, GHSA-pw54-mh39-w3hc Record: https://patchnext.com/advisories/cve-2020-7754 (revision 3, source checked 26 Oct 2026, 12:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: npm-user-validate 1.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm npm-user-validate: affected <= 1.0.0; fixed in 1.0.1 ## Suggested inspection (read-only) - `npm ls npm-user-validate --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on npm-user-validate. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pw54-mh39-w3hc (OSV record GHSA-pw54-mh39-w3hc lists affected ranges: npm npm-user-validate >=0 <1.0.1 (fixed)) - Verified: https://osv.dev/vulnerability/GHSA-xgh6-85xh-479p (OSV record GHSA-xgh6-85xh-479p lists affected ranges: npm npm-user-validate >=0 <1.0.1 (fixed)) - Verified: https://github.com/advisories/GHSA-xgh6-85xh-479p (GitHub-reviewed advisory GHSA-xgh6-85xh-479p lists affected ranges: npm npm-user-validate >=0 <=1.0.0) Commands are suggestions: review each one before running it.
Loading voting…