OS Command Injection in ng-packagr
CVE-2020-7735GHSA-qm28-7hqv-wg5j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ng-packagr 10.1.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm ng-packagr
- Affected
- < 10.1.1
- Fixed in
- 10.1.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qm28-7hqv-wg5j lists affected ranges: npm ng-packagr >=0 <10.1.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qm28-7hqv-wg5j lists affected ranges: npm ng-packagr >=0 <10.1.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.6 · CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2020-7735: 2.39% estimated exploitation activity in the next 30 days; percentile 83.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The package ng-packagr before 10.1.1 are vulnerable to Command Injection via the styleIncludePaths option.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-qm28-7hqv-wg5j
- Revision 1 · created ·
Published from osv record GHSA-qm28-7hqv-wg5j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-7735 Advisory: OS Command Injection in ng-packagr IDs: CVE-2020-7735, GHSA-qm28-7hqv-wg5j Record: https://patchnext.com/advisories/cve-2020-7735 (revision 2, source checked 26 Oct 2026, 12:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ng-packagr 10.1.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm ng-packagr: affected < 10.1.1; fixed in 10.1.1 ## Suggested inspection (read-only) - `npm ls ng-packagr --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ng-packagr. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-qm28-7hqv-wg5j (OSV record GHSA-qm28-7hqv-wg5j lists affected ranges: npm ng-packagr >=0 <10.1.1 (fixed)) - Verified: https://github.com/advisories/GHSA-qm28-7hqv-wg5j (GitHub-reviewed advisory GHSA-qm28-7hqv-wg5j lists affected ranges: npm ng-packagr >=0 <10.1.1) Commands are suggestions: review each one before running it.
Loading voting…