trentm/json vulnerable to command injection
CVE-2020-7712GHSA-3c6g-pvg8-gqw2
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm json
- Affected
- < 10.0.0
- Fixed in
- 10.0.0
Maven org.webjars.npm:json
- Affected
- <= 9.0.6
- Fixed in
- no fixed version recorded
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3c6g-pvg8-gqw2 lists affected ranges: npm json >=0 =0 <=9.0.6
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3c6g-pvg8-gqw2 lists affected ranges: npm json >=0 =0 <=9.0.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.2 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2020-7712: 3.11% estimated exploitation activity in the next 30 days; percentile 87.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
This affects the package json before 10.0.0. It is possible to inject arbritary commands using the parseLookup function.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-3c6g-pvg8-gqw2
- Revision 1 · created ·
Published from osv record GHSA-3c6g-pvg8-gqw2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-7712 Advisory: trentm/json vulnerable to command injection IDs: CVE-2020-7712, GHSA-3c6g-pvg8-gqw2 Record: https://patchnext.com/advisories/cve-2020-7712 (revision 2, source checked 26 Oct 2026, 12:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: json 10.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm json: affected < 10.0.0; fixed in 10.0.0 - Maven org.webjars.npm:json: affected <= 9.0.6 ## Suggested inspection (read-only) - `npm ls json --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - Maven org.webjars.npm:json: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on json, org.webjars.npm:json. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-3c6g-pvg8-gqw2 (OSV record GHSA-3c6g-pvg8-gqw2 lists affected ranges: npm json >=0 =0 <=9.0.6) - Verified: https://github.com/advisories/GHSA-3c6g-pvg8-gqw2 (GitHub-reviewed advisory GHSA-3c6g-pvg8-gqw2 lists affected ranges: npm json >=0 =0 <=9.0.6) Commands are suggestions: review each one before running it.
Loading voting…