Skip to content

← Actionable
High, CVSS 7.4

Improper Authorization in Google OAuth Client

CVE-2020-7692GHSA-f263-c949-w85g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.google.oauth-client:google-oauth-client 1.31.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2020-7692: 1.52% estimated exploitation activity in the next 30 days; percentile 74.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

PKCE support is not implemented in accordance with the RFC for OAuth 2.0 for Native Apps. Without the use of PKCE, the authorization code returned by an authorization server is not enough to guarantee that the client that issued the initial authorization request is the one that will be authorized. An attacker is able to obtain the authorization code using a malicious app on the client-side and use it to gain authorization to the protected resource. This affects the package com.google.oauth-client:google-oauth-client before 1.31.0.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-f263-c949-w85g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-7692

Advisory: Improper Authorization in Google OAuth Client
IDs: CVE-2020-7692, GHSA-f263-c949-w85g
Record: https://patchnext.com/advisories/cve-2020-7692 (revision 1, source checked 26 Oct 2026, 16:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: com.google.oauth-client:google-oauth-client 1.31.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven com.google.oauth-client:google-oauth-client: affected < 1.31.0; fixed in 1.31.0

## Suggested inspection (read-only)
- Maven com.google.oauth-client:google-oauth-client: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on com.google.oauth-client:google-oauth-client.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-f263-c949-w85g (GitHub-reviewed advisory GHSA-f263-c949-w85g lists affected ranges: Maven com.google.oauth-client:google-oauth-client >=0 <1.31.0)

Commands are suggestions: review each one before running it.

Loading voting…