path traversal in Jooby
CVE-2020-7647GHSA-px9h-x66r-8mpc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jooby:jooby 2.8.2; io.jooby:jooby 2.8.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.jooby:jooby
- Affected
- < 2.8.2
- Fixed in
- 2.8.2
Maven io.jooby:jooby
- Affected
- < 2.8.2
- Fixed in
- 2.8.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-px9h-x66r-8mpc lists affected ranges: Maven io.jooby:jooby >=0 =0 <2.8.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2020-7647: 1.55% estimated exploitation activity in the next 30 days; percentile 75.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Access to sensitive information available from classpath. Patches Patched version: 1.6.7 and 2.8.2 Commit 1.x: https://github.com/jooby-project/jooby/commit/34f526028e6cd0652125baa33936ffb6a8a4a009 Commit 2.x: https://github.com/jooby-project/jooby/commit/c81479de67036993f406ccdec23990b44b0bec32 Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? References Latest 1.x version: 1.6.6 Arbitrary class path resource access 1 When sharing a File System directory as in: The class path is also searched for the file (org.jooby.handlers.AssetHandler.loader): jooby/AssetHandler.java at 1.x · jooby-project/jooby · GitHub If we send /static/WEB-INF/web.xml it will fail to load it from the file system but will go into classloader.getResource(name) where name equals /WEB-INF/web.xml so will succeed and return the requested file. This way we can get any configuration file or even the application class files If assets are configured for a certain…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-px9h-x66r-8mpc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-7647 Advisory: path traversal in Jooby IDs: CVE-2020-7647, GHSA-px9h-x66r-8mpc Record: https://patchnext.com/advisories/cve-2020-7647 (revision 1, source checked 26 Oct 2026, 15:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.jooby:jooby 2.8.2; io.jooby:jooby 2.8.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.jooby:jooby: affected < 2.8.2; fixed in 2.8.2 - Maven io.jooby:jooby: affected < 2.8.2; fixed in 2.8.2 ## Suggested inspection (read-only) - Maven org.jooby:jooby: check the installed version with your package manager. - Maven io.jooby:jooby: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.jooby:jooby, io.jooby:jooby. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-px9h-x66r-8mpc (GitHub-reviewed advisory GHSA-px9h-x66r-8mpc lists affected ranges: Maven io.jooby:jooby >=0 =0 <2.8.2) Commands are suggestions: review each one before running it.
Loading voting…