yargs-parser Vulnerable to Prototype Pollution
CVE-2020-7608GHSA-p9pc-299p-vxgp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (yargs-parser 18.1.1, 15.0.1, 13.1.2, 5.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm yargs-parser
- Affected
- >= 6.0.0, < 13.1.2>= 14.0.0, < 15.0.1<= 5.0.0>= 16.0.0, < 18.1.1
- Fixed in
- 13.1.2, 15.0.1, 18.1.1, 5.0.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-p9pc-299p-vxgp lists affected ranges: npm yargs-parser >=6.0.0 =14.0.0 =16.0.0 =0 <5.0.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p9pc-299p-vxgp lists affected ranges: npm yargs-parser >=6.0.0 =14.0.0 =0 =16.0.0 <18.1.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- EPSS
- CVE-2020-7608: 0.51% estimated exploitation activity in the next 30 days; percentile 43.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected versions of yargs-parser are vulnerable to prototype pollution. Arguments are not properly sanitized, allowing an attacker to modify the prototype of Object, causing the addition or modification of an existing property that will exist on all objects. Parsing the argument --foo.proto.bar baz' adds a bar property with value baz to all objects. This is only exploitable if attackers have control over the arguments being passed to yargs-parser. Recommendation Upgrade to versions 13.1.2, 15.0.1, 18.1.1 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-p9pc-299p-vxgp
- Revision 1 · created ·
Published from osv record GHSA-p9pc-299p-vxgp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-7608 Advisory: yargs-parser Vulnerable to Prototype Pollution IDs: CVE-2020-7608, GHSA-p9pc-299p-vxgp Record: https://patchnext.com/advisories/cve-2020-7608 (revision 2, source checked 26 Oct 2026, 12:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: yargs-parser 18.1.1, 15.0.1, 13.1.2, 5.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm yargs-parser: affected >= 6.0.0, < 13.1.2; >= 14.0.0, < 15.0.1; <= 5.0.0; >= 16.0.0, < 18.1.1; fixed in 13.1.2, 15.0.1, 18.1.1, 5.0.1 ## Suggested inspection (read-only) - `npm ls yargs-parser --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on yargs-parser. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-p9pc-299p-vxgp (OSV record GHSA-p9pc-299p-vxgp lists affected ranges: npm yargs-parser >=6.0.0 =14.0.0 =16.0.0 =0 <5.0.1 (fixed)) - Verified: https://github.com/advisories/GHSA-p9pc-299p-vxgp (GitHub-reviewed advisory GHSA-p9pc-299p-vxgp lists affected ranges: npm yargs-parser >=6.0.0 =14.0.0 =0 =16.0.0 <18.1.1) Commands are suggestions: review each one before running it.
Loading voting…