Skip to content

← Actionable
High, CVSS 7.5

Denial of Service in Cryptacular

CVE-2020-7226GHSA-x64g-4xx9-fh6x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.cryptacular:cryptacular 1.2.4, 1.1.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2020-7226: 3.33% estimated exploitation activity in the next 30 days; percentile 88.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

CiphertextHeader.java in Cryptacular before 1.2.4, as used in Apereo CAS and other products, allows attackers to trigger excessive memory allocation during a decode operation, because the nonce array length associated with "new byte" may depend on untrusted input within the header of encoded data.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-x64g-4xx9-fh6x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-7226

Advisory: Denial of Service in Cryptacular
IDs: CVE-2020-7226, GHSA-x64g-4xx9-fh6x
Record: https://patchnext.com/advisories/cve-2020-7226 (revision 1, source checked 26 Oct 2026, 16:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.cryptacular:cryptacular 1.2.4, 1.1.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.cryptacular:cryptacular: affected < 1.1.4; >= 1.2.0, < 1.2.4; fixed in 1.1.4, 1.2.4

## Suggested inspection (read-only)
- Maven org.cryptacular:cryptacular: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.cryptacular:cryptacular.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-x64g-4xx9-fh6x (GitHub-reviewed advisory GHSA-x64g-4xx9-fh6x lists affected ranges: Maven org.cryptacular:cryptacular >=0 =1.2.0 <1.2.4)

Commands are suggestions: review each one before running it.

Loading voting…