Privilege Escalation Flaw in Elasticsearch
CVE-2020-7014GHSA-hqqv-9x3v-mp7w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.elasticsearch:elasticsearch 7.6.2, 6.8.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.elasticsearch:elasticsearch
- Affected
- >= 6.7.0, < 6.8.8>= 7.0.0, < 7.6.2
- Fixed in
- 6.8.8, 7.6.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hqqv-9x3v-mp7w lists affected ranges: Maven org.elasticsearch:elasticsearch >=6.7.0 =7.0.0 <7.6.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2020-7014: 1.74% estimated exploitation activity in the next 30 days; percentile 77.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The fix for CVE-2020-7009 was found to be incomplete. Elasticsearch versions from 6.7.0 to 6.8.7 and 7.0.0 to 7.6.1 contain a privilege escalation flaw if an attacker is able to create API keys and also authentication tokens. An attacker who is able to generate an API key and an authentication token can perform a series of steps that result in an authentication token being generated with elevated privileges.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-hqqv-9x3v-mp7w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-7014 Advisory: Privilege Escalation Flaw in Elasticsearch IDs: CVE-2020-7014, GHSA-hqqv-9x3v-mp7w Record: https://patchnext.com/advisories/cve-2020-7014 (revision 1, source checked 26 Oct 2026, 16:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.elasticsearch:elasticsearch 7.6.2, 6.8.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.elasticsearch:elasticsearch: affected >= 6.7.0, < 6.8.8; >= 7.0.0, < 7.6.2; fixed in 6.8.8, 7.6.2 ## Suggested inspection (read-only) - Maven org.elasticsearch:elasticsearch: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.elasticsearch:elasticsearch. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hqqv-9x3v-mp7w (GitHub-reviewed advisory GHSA-hqqv-9x3v-mp7w lists affected ranges: Maven org.elasticsearch:elasticsearch >=6.7.0 =7.0.0 <7.6.2) Commands are suggestions: review each one before running it.
Loading voting…