Incorrect threshold signature computation in TUF
CVE-2020-6174GHSA-pwqf-9h7j-7mv8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (tuf 0.12.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI tuf
- Affected
- < 0.12.2
- Fixed in
- 0.12.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pwqf-9h7j-7mv8 lists affected ranges: PyPI tuf >=0 <0.12.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pwqf-9h7j-7mv8 lists affected ranges: PyPI tuf >=0 <0.12.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2020-6174: 0.99% estimated exploitation activity in the next 30 days; percentile 62.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Metadadata signature verification, as used in tuf.client.updater, counted each of multiple signatures with identical authorized keyids separately towards the threshold. Therefore, an attacker with access to a valid signing key could create multiple valid signatures in order to meet the minimum threshold of keys before the metadata was considered valid. The tuf maintainers would like to thank Erik MacLean of Analog Devices, Inc. for reporting this issue. Patches A fix is available in version 0.12.2 or newer. Workarounds No workarounds are known for this issue. References CVE-2020-6174 Pull request resolving the issue PR 974
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-pwqf-9h7j-7mv8
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-pwqf-9h7j-7mv8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-6174 Advisory: Incorrect threshold signature computation in TUF IDs: CVE-2020-6174, GHSA-pwqf-9h7j-7mv8 Record: https://patchnext.com/advisories/cve-2020-6174 (revision 3, source checked 26 Oct 2026, 13:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: tuf 0.12.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI tuf: affected < 0.12.2; fixed in 0.12.2 ## Suggested inspection (read-only) - `python -m pip show tuf`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on tuf. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pwqf-9h7j-7mv8 (OSV record GHSA-pwqf-9h7j-7mv8 lists affected ranges: PyPI tuf >=0 <0.12.2 (fixed)) - Verified: https://github.com/advisories/GHSA-pwqf-9h7j-7mv8 (GitHub-reviewed advisory GHSA-pwqf-9h7j-7mv8 lists affected ranges: PyPI tuf >=0 <0.12.2) Commands are suggestions: review each one before running it.
Loading voting…