Skip to content

← Actionable
Medium, CVSS 6.9amended

Client Denial of Service on TUF

CVE-2020-6173GHSA-2828-9vh6-9m6j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tuf 0.12.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI tuf

    Affected
    >= 0.7.2, < 0.12.2
    Fixed in
    0.12.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2020-6173: 1.76% estimated exploitation activity in the next 30 days; percentile 77.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An attacker who can gain file access to the repository and modify metadata files may cause a denial of service to clients by creating many invalid signatures on a metadata file. Having a large number of signatures to verify will delay the moment when the client will determine the signature is not valid. This delay may be for at least a few minutes, but possibly could be longer especially if multiple files are impacted. The tuf maintainers would like to thank Erik MacLean of Analog Devices, Inc. for reporting this issue. Patches No fix exists for this issue. Workarounds No workarounds are known for this issue. References CVE-2020-6173 Issue #973

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-2828-9vh6-9m6j

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-2828-9vh6-9m6j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-6173

Advisory: Client Denial of Service on TUF
IDs: CVE-2020-6173, GHSA-2828-9vh6-9m6j
Record: https://patchnext.com/advisories/cve-2020-6173 (revision 3, source checked 26 Oct 2026, 13:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tuf 0.12.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI tuf: affected >= 0.7.2, < 0.12.2; fixed in 0.12.2

## Suggested inspection (read-only)
- `python -m pip show tuf`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tuf.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2828-9vh6-9m6j (OSV record GHSA-2828-9vh6-9m6j lists affected ranges: PyPI tuf >=0.7.2 <0.12.2 (fixed))
- Verified: https://github.com/advisories/GHSA-2828-9vh6-9m6j (GitHub-reviewed advisory GHSA-2828-9vh6-9m6j lists affected ranges: PyPI tuf >=0.7.2 <0.12.2)

Commands are suggestions: review each one before running it.

Loading voting…