Skip to content

← Actionable
High, CVSS 7.5

Silverstripe CMS information disclosure

CVE-2020-6164GHSA-gm5x-hpmw-xpxg

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist silverstripe/cms

    Affected
    <= 4.5.0
    Fixed in
    no fixed version recorded
  • Packagist silverstripe/framework

    Affected
    >= 4.0.0, < 4.4.7>= 4.5.0, < 4.5.4
    Fixed in
    4.4.7, 4.5.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2020-6164: 1.80% estimated exploitation activity in the next 30 days; percentile 78.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In SilverStripe through 4.5.0, a specific URL path configured by default through the silverstripe/framework module can be used to disclose the fact that a domain is hosting a Silverstripe application. There is no disclosure of the specific version. The functionality on this URL path is limited to execution in a CLI context, and is not known to present a vulnerability through web-based access. As a side-effect, this preconfigured path also blocks the creation of other resources on this path (e.g. a page).

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gm5x-hpmw-xpxg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-6164

Advisory: Silverstripe CMS information disclosure
IDs: CVE-2020-6164, GHSA-gm5x-hpmw-xpxg
Record: https://patchnext.com/advisories/cve-2020-6164 (revision 1, source checked 26 Oct 2026, 14:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: silverstripe/framework 4.5.4, 4.4.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist silverstripe/cms: affected <= 4.5.0
- Packagist silverstripe/framework: affected >= 4.0.0, < 4.4.7; >= 4.5.0, < 4.5.4; fixed in 4.4.7, 4.5.4

## Suggested inspection (read-only)
- Packagist silverstripe/cms: check the installed version with your package manager.
- Packagist silverstripe/framework: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on silverstripe/cms, silverstripe/framework.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gm5x-hpmw-xpxg (GitHub-reviewed advisory GHSA-gm5x-hpmw-xpxg lists affected ranges: Packagist silverstripe/cms >=0 =4.0.0 =4.5.0 <4.5.4)

Commands are suggestions: review each one before running it.

Loading voting…