Skip to content

← Actionable
Medium, CVSS 6.5

Insufficient Entropy in Spring Security

CVE-2020-5408GHSA-2ppp-9496-p23q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.springframework.security:spring-security-core 5.3.2, 5.2.4, 5.1.10, 5.0.16, 4.2.16), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-2ppp-9496-p23q lists affected ranges: Maven org.springframework.security:spring-security-core >=5.3.0 =5.2.0 =5.1.0 =5.0.0 =0 <4.2.16

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2020-5408: 1.59% estimated exploitation activity in the next 30 days; percentile 75.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Spring Security versions 5.3.x prior to 5.3.2, 5.2.x prior to 5.2.4, 5.1.x prior to 5.1.10, 5.0.x prior to 5.0.16 and 4.2.x prior to 4.2.16 use a fixed null initialization vector with CBC Mode in the implementation of the queryable text encryptor. A malicious user with access to the data that has been encrypted using such an encryptor may be able to derive the unencrypted values using a dictionary attack.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-2ppp-9496-p23q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-5408

Advisory: Insufficient Entropy in Spring Security
IDs: CVE-2020-5408, GHSA-2ppp-9496-p23q
Record: https://patchnext.com/advisories/cve-2020-5408 (revision 1, source checked 26 Oct 2026, 16:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.springframework.security:spring-security-core 5.3.2, 5.2.4, 5.1.10, 5.0.16, 4.2.16. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.springframework.security:spring-security-core: affected >= 5.3.0, < 5.3.2; >= 5.2.0, < 5.2.4; >= 5.1.0, < 5.1.10; >= 5.0.0, < 5.0.16; < 4.2.16; fixed in 5.3.2, 5.0.16, 5.1.10, 5.2.4, 4.2.16

## Suggested inspection (read-only)
- Maven org.springframework.security:spring-security-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.springframework.security:spring-security-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2ppp-9496-p23q (GitHub-reviewed advisory GHSA-2ppp-9496-p23q lists affected ranges: Maven org.springframework.security:spring-security-core >=5.3.0 =5.2.0 =5.1.0 =5.0.0 =0 <4.2.16)

Commands are suggestions: review each one before running it.

Loading voting…