Signature wrapping vulnerability in Spring Security
CVE-2020-5407GHSA-48rw-j489-928m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.springframework.security:spring-security-core 5.3.2, 5.2.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.springframework.security:spring-security-core
- Affected
- >= 5.2.0, < 5.2.4>= 5.3.0, < 5.3.2
- Fixed in
- 5.3.2, 5.2.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-48rw-j489-928m lists affected ranges: Maven org.springframework.security:spring-security-core >=5.2.0 =5.3.0 <5.3.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2020-5407: 1.20% estimated exploitation activity in the next 30 days; percentile 68.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Spring Security versions 5.2.x prior to 5.2.4 and 5.3.x prior to 5.3.2 contain a signature wrapping vulnerability during SAML response validation. When using the spring-security-saml2-service-provider component, a malicious user can carefully modify an otherwise valid SAML response and append an arbitrary assertion that Spring Security will accept as valid.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-48rw-j489-928m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-5407 Advisory: Signature wrapping vulnerability in Spring Security IDs: CVE-2020-5407, GHSA-48rw-j489-928m Record: https://patchnext.com/advisories/cve-2020-5407 (revision 1, source checked 26 Oct 2026, 16:05 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.springframework.security:spring-security-core 5.3.2, 5.2.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.springframework.security:spring-security-core: affected >= 5.2.0, < 5.2.4; >= 5.3.0, < 5.3.2; fixed in 5.3.2, 5.2.4 ## Suggested inspection (read-only) - Maven org.springframework.security:spring-security-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.springframework.security:spring-security-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-48rw-j489-928m (GitHub-reviewed advisory GHSA-48rw-j489-928m lists affected ranges: Maven org.springframework.security:spring-security-core >=5.2.0 =5.3.0 <5.3.2) Commands are suggestions: review each one before running it.
Loading voting…