Information disclosure of source code in SimpleSAMLphp
CVE-2020-5301GHSA-24m3-w8g9-jwpq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (simplesamlphp/simplesamlphp 1.18.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist simplesamlphp/simplesamlphp
- Affected
- < 1.18.6
- Fixed in
- 1.18.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-24m3-w8g9-jwpq lists affected ranges: Packagist simplesamlphp/simplesamlphp >=0 <1.18.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.0 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:N/A:N
- EPSS
- CVE-2020-5301: 0.92% estimated exploitation activity in the next 30 days; percentile 60.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Background The module controller in SimpleSAML\Module that processes requests for pages hosted by modules, has code to identify paths ending with .php and process those as PHP code. If no other suitable way of handling the given path exists it presents the file to the browser. Description The check to identify paths ending with .php does not account for uppercase letters. If someone requests a path ending with e.g. .PHP and the server is serving the code from a case-insensitive file system, such as on Windows, the processing of the PHP code does not occur, and the source code is instead presented to the browser. Affected versions SimpleSAMLphp versions 1.18.5 and older. Impact An attacker may use this issue to gain access to the source code in third-party modules that is meant to be private, or even sensitive. However, the attack surface is considered small, as the attack will only work when SimpleSAMLphp serves such content from a file system that is not case-sensitive, such as on…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-24m3-w8g9-jwpq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-5301 Advisory: Information disclosure of source code in SimpleSAMLphp IDs: CVE-2020-5301, GHSA-24m3-w8g9-jwpq Record: https://patchnext.com/advisories/cve-2020-5301 (revision 1, source checked 26 Oct 2026, 14:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: simplesamlphp/simplesamlphp 1.18.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist simplesamlphp/simplesamlphp: affected < 1.18.6; fixed in 1.18.6 ## Suggested inspection (read-only) - Packagist simplesamlphp/simplesamlphp: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on simplesamlphp/simplesamlphp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-24m3-w8g9-jwpq (GitHub-reviewed advisory GHSA-24m3-w8g9-jwpq lists affected ranges: Packagist simplesamlphp/simplesamlphp >=0 <1.18.6) Commands are suggestions: review each one before running it.
Loading voting…