Skip to content

← Actionable
Medium, CVSS 4.0

Potential CSV Injection vector in OctoberCMS

CVE-2020-5299GHSA-4rhm-m2fp-hx7q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (october/backend 1.0.466), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.0 · CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2020-5299: 1.00% estimated exploitation activity in the next 30 days; percentile 62.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Any users with the ability to modify any data that could eventually be exported as a CSV file from the ImportExportController could potentially introduce a CSV injection into the data to cause the generated CSV export file to be malicious. This requires attackers to achieve the following before a successful attack can be completed: 1. Have found a vulnerability in the victim's spreadsheet software of choice. 2. Control data that would potentially be exported through the ImportExportController by a theoretical victim. 3. Convince the victim to export above data as a CSV and run it in vulnerable spreadsheet software while also bypassing any sanity checks by said software. Patches Issue has been patched in Build 466 (v1.0.466). Workarounds Apply https://github.com/octobercms/library/commit/c84bf03f506052c848f2fddc05f24be631427a1a & https://github.com/octobercms/october/commit/802d8c8e09a2b342649393edb6d3ceb958851484 to your installation manually if unable to upgrade to Build 466.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4rhm-m2fp-hx7q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-5299

Advisory: Potential CSV Injection vector in OctoberCMS
IDs: CVE-2020-5299, GHSA-4rhm-m2fp-hx7q
Record: https://patchnext.com/advisories/cve-2020-5299 (revision 1, source checked 26 Oct 2026, 14:01 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: october/backend 1.0.466. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist october/backend: affected >= 1.0.319, < 1.0.466; fixed in 1.0.466

## Suggested inspection (read-only)
- Packagist october/backend: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on october/backend.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4rhm-m2fp-hx7q (GitHub-reviewed advisory GHSA-4rhm-m2fp-hx7q lists affected ranges: Packagist october/backend >=1.0.319 <1.0.466)

Commands are suggestions: review each one before running it.

Loading voting…