Skip to content

← Actionable
High, CVSS 7.6

Firewall configured with unanimous strategy was not actually unanimous in Symfony

CVE-2020-5275GHSA-g4m9-5hpf-hx72

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (symfony/symfony 5.0.7, 4.4.7; symfony/security-http 5.0.7, 4.4.7; symfony/security 5.0.7, 4.4.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist symfony/symfony

    Affected
    >= 4.4.0, < 4.4.7>= 5.0.0, < 5.0.7
    Fixed in
    4.4.7, 5.0.7
  • Packagist symfony/security-http

    Affected
    >= 4.4.0, < 4.4.7>= 5.0.0, < 5.0.7
    Fixed in
    4.4.7, 5.0.7
  • Packagist symfony/security

    Affected
    >= 4.4.0, < 4.4.7>= 5.0.0, < 5.0.7
    Fixed in
    4.4.7, 5.0.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:N
EPSS
  • CVE-2020-5275: 1.15% estimated exploitation activity in the next 30 days; percentile 66.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description ----------- On Symfony before 4.4.0, when a Firewall checks an access control rule (using the unanimous strategy), it iterates over all rule attributes and grant access only if all calls to the accessDecisionManager decide to grant access. As of Symfony 4.4.0, a bug was introduced that prevents the check of attributes as soon as accessDecisionManager decide to grant access on one attribute. Resolution ---------- The accessDecisionManager is now called with all attributes at once, allowing the unanimous strategy being applied on each attribute. The patch for this issue is available here for the 4.4 branch. Credits ------- I would like to thank Antonio J. García Lagar for reporting & Robin Chalas for fixing the issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-g4m9-5hpf-hx72

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-5275

Advisory: Firewall configured with unanimous strategy was not actually unanimous in Symfony
IDs: CVE-2020-5275, GHSA-g4m9-5hpf-hx72
Record: https://patchnext.com/advisories/cve-2020-5275 (revision 1, source checked 26 Oct 2026, 14:15 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: symfony/symfony 5.0.7, 4.4.7; symfony/security-http 5.0.7, 4.4.7; symfony/security 5.0.7, 4.4.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist symfony/symfony: affected >= 4.4.0, < 4.4.7; >= 5.0.0, < 5.0.7; fixed in 4.4.7, 5.0.7
- Packagist symfony/security-http: affected >= 4.4.0, < 4.4.7; >= 5.0.0, < 5.0.7; fixed in 4.4.7, 5.0.7
- Packagist symfony/security: affected >= 4.4.0, < 4.4.7; >= 5.0.0, < 5.0.7; fixed in 4.4.7, 5.0.7

## Suggested inspection (read-only)
- Packagist symfony/symfony: check the installed version with your package manager.
- Packagist symfony/security-http: check the installed version with your package manager.
- Packagist symfony/security: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on symfony/symfony, symfony/security-http, symfony/security.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-g4m9-5hpf-hx72 (GitHub-reviewed advisory GHSA-g4m9-5hpf-hx72 lists affected ranges: Packagist symfony/security >=4.4.0 =5.0.0 =4.4.0 =5.0.0 =4.4.0 =5.0.0 <5.0.7)

Commands are suggestions: review each one before running it.

Loading voting…