Skip to content

← Actionable
Medium, CVSS 4.8

Cross site scripting vulnerability in ActionView

CVE-2020-5267GHSA-65cv-r6x7-79hv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (actionview 6.0.2.2, 5.2.4.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems actionview

    Affected
    <= 5.2.4.1>= 6.0.0, <= 6.0.2.1
    Fixed in
    5.2.4.2, 6.0.2.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.8 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2020-5267: 1.52% estimated exploitation activity in the next 30 days; percentile 74.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

There is a possible cross site scripting (XSS) vulnerability in ActionView's JavaScript literal escape helpers. Views that use the j or escapejavascript methods may be susceptible to XSS attacks. Impact There is a possible XSS vulnerability in the j and escapejavascript methods in ActionView. These methods are used for escaping JavaScript string literals. Impacted code will look something like this: or Releases The 6.0.2.2 and 5.2.4.2 releases are available at the normal locations. Workarounds For those that can't upgrade, the following monkey patch may be used: Patches To aid users who aren't able to upgrade immediately we have provided patches for the two supported release series. They are in git-am format and consist of a single changeset. 5-2-js-helper-xss.patch - Patch for 5.2 series 6-0-js-helper-xss.patch - Patch for 6.0 series Please note that only the 5.2 and 6.0 series are supported at present. Users of earlier unsupported releases are advised to upgrade as soon as possible…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-65cv-r6x7-79hv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-5267

Advisory: Cross site scripting vulnerability in ActionView
IDs: CVE-2020-5267, GHSA-65cv-r6x7-79hv
Record: https://patchnext.com/advisories/cve-2020-5267 (revision 1, source checked 26 Oct 2026, 15:44 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: actionview 6.0.2.2, 5.2.4.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems actionview: affected <= 5.2.4.1; >= 6.0.0, <= 6.0.2.1; fixed in 5.2.4.2, 6.0.2.2

## Suggested inspection (read-only)
- RubyGems actionview: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on actionview.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-65cv-r6x7-79hv (GitHub-reviewed advisory GHSA-65cv-r6x7-79hv lists affected ranges: RubyGems actionview >=0 =6.0.0 <=6.0.2.1)

Commands are suggestions: review each one before running it.

Loading voting…