Skip to content

← Actionable
Medium, CVSS 5.5amended

Information disclosure through error object in auth0.js

CVE-2020-5263GHSA-prfq-f66g-43mp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (auth0-js 9.13.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm auth0-js

    Affected
    >= 8.0.0, < 9.13.2
    Fixed in
    9.13.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.5 · CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:C/C:H/I:N/A:N
EPSS
  • CVE-2020-5263: 0.87% estimated exploitation activity in the next 30 days; percentile 58.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Overview Between versions 8.0.0 and 9.13.1(inclusive), in the case of an (authentication) error, the error object returned by the library contains the original request of the user, which may include the plaintext password the user entered. If the error object is exposed or logged without modification, the application risks password exposure. Am I affected? You are affected by this vulnerability if all of the following conditions apply: - You are using Auth0.js version between 8.0.0 and 9.13.1(inclusive). - You store or display error objects without filtering. How to fix that? Developers should upgrade auth0.js to version 9.13.2 or later where user inputted passwords are masked in errors. If upgrading is not possible, a temporary fix may include not storing the error object or displaying it publicly without modification. Will this update impact my users? This fix patches the Auth0.js and may require changes in application code due to password no longer available in error object, but…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-prfq-f66g-43mp

  2. Revision 1 · created ·

    Published from osv record GHSA-prfq-f66g-43mp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-5263

Advisory: Information disclosure through error object in auth0.js
IDs: CVE-2020-5263, GHSA-prfq-f66g-43mp
Record: https://patchnext.com/advisories/cve-2020-5263 (revision 2, source checked 26 Oct 2026, 12:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: auth0-js 9.13.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm auth0-js: affected >= 8.0.0, < 9.13.2; fixed in 9.13.2

## Suggested inspection (read-only)
- `npm ls auth0-js --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on auth0-js.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-prfq-f66g-43mp (OSV record GHSA-prfq-f66g-43mp lists affected ranges: npm auth0-js >=8.0.0 <9.13.2 (fixed))
- Verified: https://github.com/advisories/GHSA-prfq-f66g-43mp (GitHub-reviewed advisory GHSA-prfq-f66g-43mp lists affected ranges: npm auth0-js >=8.0.0 <9.13.2)

Commands are suggestions: review each one before running it.

Loading voting…