Skip to content

← Actionable
Low, CVSS 2.6

Prevent cache poisoning via a Response Content-Type header in Symfony

CVE-2020-5255GHSA-mcx4-f5f5-4859

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (symfony/symfony 5.0.7, 4.4.7; symfony/http-foundation 5.0.7, 4.4.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
2.6 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:N/I:N/A:L
EPSS
  • CVE-2020-5255: 1.30% estimated exploitation activity in the next 30 days; percentile 70.42 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description ----------- When a Response does not contain a Content-Type header, Symfony falls back to the format defined in the Accept header of the request, leading to a possible mismatch between the response's content and Content-Type header. When the response is cached, this can lead to a corrupted cache where the cached format is not the right one. Resolution ---------- Symfony does not use the Accept header anymore to guess the Content-Type. The patch for this issue is available here for the 4.4 branch. Credits ------- I would like to thank Xavier Lacot from JoliCode for reporting & Yonel Ceruto and Tobias Schultze for fixing the issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-mcx4-f5f5-4859

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-5255

Advisory: Prevent cache poisoning via a Response Content-Type header in Symfony
IDs: CVE-2020-5255, GHSA-mcx4-f5f5-4859
Record: https://patchnext.com/advisories/cve-2020-5255 (revision 1, source checked 26 Oct 2026, 14:15 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: symfony/symfony 5.0.7, 4.4.7; symfony/http-foundation 5.0.7, 4.4.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist symfony/symfony: affected >= 4.4.0, < 4.4.7; >= 5.0.0, < 5.0.7; fixed in 4.4.7, 5.0.7
- Packagist symfony/http-foundation: affected >= 4.4.0, < 4.4.7; >= 5.0.0, < 5.0.7; fixed in 4.4.7, 5.0.7

## Suggested inspection (read-only)
- Packagist symfony/symfony: check the installed version with your package manager.
- Packagist symfony/http-foundation: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on symfony/symfony, symfony/http-foundation.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-mcx4-f5f5-4859 (GitHub-reviewed advisory GHSA-mcx4-f5f5-4859 lists affected ranges: Packagist symfony/http-foundation >=4.4.0 =5.0.0 =4.4.0 =5.0.0 <5.0.7)

Commands are suggestions: review each one before running it.

Loading voting…