Skip to content

← Actionable
Medium, CVSS 5.0amended

Malicious package may avoid detection in python auditing

CVE-2020-5252GHSA-7q25-qrjw-6fg2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (safety 1.9.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI safety

    Affected
    < 1.9.0
    Fixed in
    1.9.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.0 · CVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:C/C:N/I:H/A:N
EPSS
  • CVE-2020-5252: 0.37% estimated exploitation activity in the next 30 days; percentile 30.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Python Auditing Vulnerability Demonstrates how a malicious package can insert a load-time poison pill to avoid detection by tools like Safety. Tools that are designed to find vulnerable packages can not ever run in the same python environment that they are trying to protect. Usage Install safety, insecure-package, and this package with pip in the same python environment. Order doesn&amp;#39;t matter. 1. pip install safety 2. pip install insecure-package 3. pip install dist/malicious-0.1-py3-none-any.whl Run the check 4. safety check You should see both Running my modified safety.check and that insecure-package is not listed in the results! How it Works Everything in Python is mutable. The trick is getting some code to run at interpreter load time in order to do some patching. 1. When you install this package, the setup.py settings installs a malicious.pth file to your site-packages directory. 2. The malicious.pth file gets loaded anytime Python starts, which in turn imports our…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-7q25-qrjw-6fg2

  2. Revision 1 · created ·

    Published from osv record GHSA-7q25-qrjw-6fg2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-5252

Advisory: Malicious package may avoid detection in python auditing
IDs: CVE-2020-5252, GHSA-7q25-qrjw-6fg2
Record: https://patchnext.com/advisories/cve-2020-5252 (revision 2, source checked 26 Oct 2026, 13:22 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: safety 1.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI safety: affected < 1.9.0; fixed in 1.9.0

## Suggested inspection (read-only)
- `python -m pip show safety`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on safety.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7q25-qrjw-6fg2 (OSV record GHSA-7q25-qrjw-6fg2 lists affected ranges: PyPI safety >=0 <1.9.0 (fixed))
- Verified: https://github.com/advisories/GHSA-7q25-qrjw-6fg2 (GitHub-reviewed advisory GHSA-7q25-qrjw-6fg2 lists affected ranges: PyPI safety >=0 <1.9.0)

Commands are suggestions: review each one before running it.

Loading voting…