Skip to content

← Actionable
High, CVSS 8.8

Relative Path Traversal (CWE-23) in chunked uploads in oneup/uploader-bundle

CVE-2020-5237GHSA-x8wj-6m73-gfqp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (oneup/uploader-bundle 2.1.5, 1.9.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2020-5237: 3.93% estimated exploitation activity in the next 30 days; percentile 90.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The vulnerability was identified in the web service for a chunked file upload. While the names of the POST parameters vary with the used frontend, their values are always used in the same way to build a path where the chunks are stored and assembled temporarily. By not validating these parameters properly, OneupUploaderBundle is susceptible to a path traversal vulnerability which can be exploited to upload files to arbitrary folders on the filesystem. The assembly process can further be misused with some restrictions to delete and copy files to other locations. The vulnerability can be exploited by any users that have legitimate access to the upload functionality and can lead to arbitrary code execution, denial of service and disclosure of confidential information. Patches Yes, see version 1.9.3 and 2.1.5. References https://owasp.org/www-community/attacks/PathTraversal Credits: This security vulnerability was found by Thibaud Kehler of SySS GmbH. E-Mail: thibaud.kehler@syss.de

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-x8wj-6m73-gfqp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-5237

Advisory: Relative Path Traversal (CWE-23) in chunked uploads in oneup/uploader-bundle
IDs: CVE-2020-5237, GHSA-x8wj-6m73-gfqp
Record: https://patchnext.com/advisories/cve-2020-5237 (revision 1, source checked 26 Oct 2026, 14:15 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: oneup/uploader-bundle 2.1.5, 1.9.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist oneup/uploader-bundle: affected >= 2.0.0, < 2.1.5; >= 1.0.0, < 1.9.3; fixed in 2.1.5, 1.9.3

## Suggested inspection (read-only)
- Packagist oneup/uploader-bundle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on oneup/uploader-bundle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-x8wj-6m73-gfqp (GitHub-reviewed advisory GHSA-x8wj-6m73-gfqp lists affected ranges: Packagist oneup/uploader-bundle >=2.0.0 =1.0.0 <1.9.3)

Commands are suggestions: review each one before running it.

Loading voting…