Catastrophic backtracking in regex allows Denial of Service in Waitress
CVE-2020-5236GHSA-73m2-3pwg-5fgc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (waitress 1.4.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI waitress
- Affected
- >= 1.4.2, <= 1.4.2
- Fixed in
- 1.4.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-73m2-3pwg-5fgc lists affected ranges: PyPI waitress >=1.4.2 <1.4.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-73m2-3pwg-5fgc lists affected ranges: PyPI waitress >=1.4.2 <=1.4.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2020-5236: 2.36% estimated exploitation activity in the next 30 days; percentile 83.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact When waitress receives a header that contains invalid characters it will cause the regular expression engine to catastrophically backtrack causing the process to use 100% CPU time and blocking any other interactions. This would allow an attacker to send a single request with an invalid header and take the service offline. Invalid header example: Increasing the number of x's in the header will increase the amount of time Waitress spends in the regular expression engine. This issue was introduced in version 1.4.2 when the regular expression was updated to attempt to match the behaviour required by errata associated with RFC7230. Patches The regular expression that is used to validate incoming headers has been updated in version 1.4.3, it is recommended that people upgrade to the new version of Waitress as soon as possible. Workarounds If you have deployed a reverse proxy in front of Waitress it may already be rejecting requests that include invalid headers. Thanks The Pylons…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-73m2-3pwg-5fgc
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-73m2-3pwg-5fgc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-5236 Advisory: Catastrophic backtracking in regex allows Denial of Service in Waitress IDs: CVE-2020-5236, GHSA-73m2-3pwg-5fgc Record: https://patchnext.com/advisories/cve-2020-5236 (revision 3, source checked 26 Oct 2026, 13:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: waitress 1.4.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI waitress: affected >= 1.4.2, <= 1.4.2; fixed in 1.4.3 ## Suggested inspection (read-only) - `python -m pip show waitress`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on waitress. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-73m2-3pwg-5fgc (OSV record GHSA-73m2-3pwg-5fgc lists affected ranges: PyPI waitress >=1.4.2 <1.4.3 (fixed)) - Verified: https://github.com/advisories/GHSA-73m2-3pwg-5fgc (GitHub-reviewed advisory GHSA-73m2-3pwg-5fgc lists affected ranges: PyPI waitress >=1.4.2 <=1.4.2) Commands are suggestions: review each one before running it.
Loading voting…