Unsafe Identifiers in Opencast
CVE-2020-5230GHSA-w29m-fjp4-qhmq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.opencastproject:base 8.1, 7.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.opencastproject:base
- Affected
- < 7.6>= 8.0, < 8.1
- Fixed in
- 8.1, 7.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w29m-fjp4-qhmq lists affected ranges: Maven org.opencastproject:base >=0 =8.0 <8.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.7 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N
- EPSS
- CVE-2020-5230: 1.17% estimated exploitation activity in the next 30 days; percentile 67.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Opencast allows almost arbitrary identifiers for media packages and elements to be used. This can be problematic for operation and security since such identifiers are sometimes used for file system operations which may lead to an attacker being able to escape working directories and write files to other locations. In addition, Opencast's Id.toString(…) vs Id.compact(…) behavior, the latter trying to mitigate some of the file system problems, can cause errors due to identifier mismatch since an identifier may unintentionally change. Patches This issue is fixed in Opencast 7.6 and 8.1. Workarounds There is no workaround for this. For more information If you have any questions or comments about this advisory: - Open an issue in opencast/opencast - For security-relevant information, email us at security@opencast.org
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-w29m-fjp4-qhmq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-5230 Advisory: Unsafe Identifiers in Opencast IDs: CVE-2020-5230, GHSA-w29m-fjp4-qhmq Record: https://patchnext.com/advisories/cve-2020-5230 (revision 1, source checked 26 Oct 2026, 15:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.opencastproject:base 8.1, 7.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.opencastproject:base: affected < 7.6; >= 8.0, < 8.1; fixed in 8.1, 7.6 ## Suggested inspection (read-only) - Maven org.opencastproject:base: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.opencastproject:base. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-w29m-fjp4-qhmq (GitHub-reviewed advisory GHSA-w29m-fjp4-qhmq lists affected ranges: Maven org.opencastproject:base >=0 =8.0 <8.1) Commands are suggestions: review each one before running it.
Loading voting…