Skip to content

← Actionable
Medium, CVSS 4.4

Log injection in SimpleSAMLphp

CVE-2020-5225GHSA-6gc6-m364-85ww

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (simplesamlphp/simplesamlphp 1.18.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.4 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2020-5225: 0.66% estimated exploitation activity in the next 30 days; percentile 51.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Background SimpleSAMLphp has a logging functionality that allows system administrators to keep track of the activity, errors, and statistics. Additionally, it allows users to report errors, shall they happen. An error report contains a report identifier, which is logged once submitted. Description The www/erroreport.php script, which receives error reports and sends them via email to the system administrator, didn't properly sanitize the report identifier obtained from the request. This allows an attacker, under specific circumstances, to inject new log lines by manually crafting this report ID. When configured to use the file logging handler, SimpleSAMLphp will output all its logs by appending each log line to a given file. Since the reportID parameter received in a request sent to www/errorreport.php was not properly sanitized, it was possible to inject newline characters into it, effectively allowing a malicious user to inject new log lines with arbitrary content. Affected…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-6gc6-m364-85ww

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-5225

Advisory: Log injection in SimpleSAMLphp
IDs: CVE-2020-5225, GHSA-6gc6-m364-85ww
Record: https://patchnext.com/advisories/cve-2020-5225 (revision 1, source checked 26 Oct 2026, 13:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: simplesamlphp/simplesamlphp 1.18.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist simplesamlphp/simplesamlphp: affected < 1.18.4; fixed in 1.18.4

## Suggested inspection (read-only)
- Packagist simplesamlphp/simplesamlphp: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on simplesamlphp/simplesamlphp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6gc6-m364-85ww (GitHub-reviewed advisory GHSA-6gc6-m364-85ww lists affected ranges: Packagist simplesamlphp/simplesamlphp >=0 <1.18.4)

Commands are suggestions: review each one before running it.

Loading voting…