Persistent XSS vulnerability in filename of attached file in PrivateBin
CVE-2020-5223GHSA-8j72-p2wm-6738
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (privatebin/privatebin 1.3.2, 1.2.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist privatebin/privatebin
- Affected
- < 1.2.2>= 1.3.0, < 1.3.2
- Fixed in
- 1.2.2, 1.3.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8j72-p2wm-6738 lists affected ranges: Packagist privatebin/privatebin >=0 =1.3.0 <1.3.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:H/I:L/A:N
- EPSS
- CVE-2020-5223: 0.66% estimated exploitation activity in the next 30 days; percentile 51.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
On 24th of December 2019 one of the property based unit tests reported a failure. Upon investigation, @elrido discovered that the failure was due to unescaped HTML, which allowed the user provided attachment file name to inject HTML under certain conditions leading to a persistent Cross-site scripting (XSS) vulnerability. After committing an initial fix to the master branch, the issue was reported on 25th of December. Vulnerability write-up done by @rugk and @elrido. The vulnerability has been fixed in PrivateBin v1.3.2 & v1.2.2. Admins are urged to upgrade to these versions to protect the affected users. Affected versions Any PrivateBin version since 1.2. Conditions The configuration setting fileupload has to be enabled, as 1.3 displays an error when trying to open a paste with attachment. The CSP header rules don't get applied. For example: They are unsupported or disabled in the visitors browser. They are filtered out by a some proxy server at the server or client side. The header…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8j72-p2wm-6738
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-5223 Advisory: Persistent XSS vulnerability in filename of attached file in PrivateBin IDs: CVE-2020-5223, GHSA-8j72-p2wm-6738 Record: https://patchnext.com/advisories/cve-2020-5223 (revision 1, source checked 26 Oct 2026, 13:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: privatebin/privatebin 1.3.2, 1.2.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist privatebin/privatebin: affected < 1.2.2; >= 1.3.0, < 1.3.2; fixed in 1.2.2, 1.3.2 ## Suggested inspection (read-only) - Packagist privatebin/privatebin: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on privatebin/privatebin. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8j72-p2wm-6738 (GitHub-reviewed advisory GHSA-8j72-p2wm-6738 lists affected ranges: Packagist privatebin/privatebin >=0 =1.3.0 <1.3.2) Commands are suggestions: review each one before running it.
Loading voting…