Ability to expose data in Sylius by using an unintended serialisation group
CVE-2020-5220GHSA-8vp7-j5cj-vvm2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sylius/sylius 1.4.4, 1.3.12; sylius/resource-bundle 1.6.3, 1.5.1, 1.4.6, 1.3.13), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist sylius/sylius
- Affected
- < 1.3.12>= 1.4.0, < 1.4.4
- Fixed in
- 1.3.12, 1.4.4
Packagist sylius/resource-bundle
- Affected
- >= 1.4.0, < 1.4.6>= 1.5.0, < 1.5.1>= 1.6.0, < 1.6.3>= 1.0.0, < 1.3.13
- Fixed in
- 1.6.3, 1.3.13, 1.4.6, 1.5.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8vp7-j5cj-vvm2 lists affected ranges: Packagist sylius/resource-bundle >=1.4.0 =1.5.0 =1.6.0 =1.0.0 =0 =1.4.0 <1.4.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.4 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2020-5220: 0.74% estimated exploitation activity in the next 30 days; percentile 54.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact ResourceBundle accepts and uses any serialisation groups to be passed via a HTTP header. This might lead to data exposure by using an unintended serialisation group - for example it could make Shop API use a more permissive group from Admin API. Anyone exposing an API with ResourceBundle's controller is affected. The vulnerable versions are: <1.3 || =1.3.0 <=1.3.12 || =1.4.0 <=1.4.5 || =1.5.0 <=1.5.0 || =1.6.0 <=1.6.2. Patches The patch is provided for ResourceBundle 1.3.13, 1.4.6, 1.5.1 and 1.6.3, but not for any versions below 1.3. After it is applied, It allows to choose only the groups that are defined in serializationgroups or allowedserializationgroups route definition. Any group not defined in those will not be used. This behaviour might be a BC break for those using custom groups via the HTTP header, please adjust allowedserializationgroups accordingly. Workarounds Service sylius.resourcecontroller.requestconfigurationfactory can be overridden with an implementation…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8vp7-j5cj-vvm2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-5220 Advisory: Ability to expose data in Sylius by using an unintended serialisation group IDs: CVE-2020-5220, GHSA-8vp7-j5cj-vvm2 Record: https://patchnext.com/advisories/cve-2020-5220 (revision 1, source checked 26 Oct 2026, 14:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sylius/sylius 1.4.4, 1.3.12; sylius/resource-bundle 1.6.3, 1.5.1, 1.4.6, 1.3.13. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist sylius/sylius: affected < 1.3.12; >= 1.4.0, < 1.4.4; fixed in 1.3.12, 1.4.4 - Packagist sylius/resource-bundle: affected >= 1.4.0, < 1.4.6; >= 1.5.0, < 1.5.1; >= 1.6.0, < 1.6.3; >= 1.0.0, < 1.3.13; fixed in 1.6.3, 1.3.13, 1.4.6, 1.5.1 ## Suggested inspection (read-only) - Packagist sylius/sylius: check the installed version with your package manager. - Packagist sylius/resource-bundle: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sylius/sylius, sylius/resource-bundle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8vp7-j5cj-vvm2 (GitHub-reviewed advisory GHSA-8vp7-j5cj-vvm2 lists affected ranges: Packagist sylius/resource-bundle >=1.4.0 =1.5.0 =1.6.0 =1.0.0 =0 =1.4.0 <1.4.4) Commands are suggestions: review each one before running it.
Loading voting…