Remote Code Execution in Angular Expressions
CVE-2020-5219GHSA-hxhm-96pp-2m43
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (angular-expressions 1.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.0.1
- Fixed in
- 1.0.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hxhm-96pp-2m43 lists affected ranges: npm angular-expressions >=0 <1.0.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hxhm-96pp-2m43 lists affected ranges: npm angular-expressions >=0 <1.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
- EPSS
- CVE-2020-5219: 2.39% estimated exploitation activity in the next 30 days; percentile 84.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The vulnerability, reported by GoSecure Inc, allows Remote Code Execution, if you call expressions.compile(userControlledInput) where userControlledInput is text that comes from user input. If running angular-expressions in the browser, an attacker could run any browser script when the application code calls expressions.compile(userControlledInput). If running angular-expressions on the server, an attacker could run any Javascript expression, thus gaining Remote Code Execution. Patches Users should upgrade to version 1.0.1 of angular-expressions Workarounds A temporary workaround might be either to : disable user-controlled input that will be fed into angular-expressions in your application OR allow only following characters in the userControlledInput : References Removal of angular-expression sandbox For more information If you have any questions or comments about this advisory: Open an issue in angular-expressions Email us Credits The issue was reported by Maxime Nadeau from…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-hxhm-96pp-2m43
- Revision 1 · created ·
Published from osv record GHSA-hxhm-96pp-2m43
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-5219 Advisory: Remote Code Execution in Angular Expressions IDs: CVE-2020-5219, GHSA-hxhm-96pp-2m43 Record: https://patchnext.com/advisories/cve-2020-5219 (revision 2, source checked 26 Oct 2026, 12:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: angular-expressions 1.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm angular-expressions: affected < 1.0.1; fixed in 1.0.1 ## Suggested inspection (read-only) - `npm ls angular-expressions --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on angular-expressions. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hxhm-96pp-2m43 (OSV record GHSA-hxhm-96pp-2m43 lists affected ranges: npm angular-expressions >=0 <1.0.1 (fixed)) - Verified: https://github.com/advisories/GHSA-hxhm-96pp-2m43 (GitHub-reviewed advisory GHSA-hxhm-96pp-2m43 lists affected ranges: npm angular-expressions >=0 <1.0.1) Commands are suggestions: review each one before running it.
Loading voting…