Skip to content

← Actionable
Medium, CVSS 4.4

Ability to switch channels via GET parameter enabled in production environments

CVE-2020-5218GHSA-prg5-hg25-8grq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (sylius/sylius 1.6.5, 1.5.9, 1.4.12, 1.3.16), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist sylius/sylius

    Affected
    < 1.3.16>= 1.4.0, < 1.4.12>= 1.5, < 1.5.9>= 1.6.0, < 1.6.5
    Fixed in
    1.6.5, 1.5.9, 1.3.16, 1.4.12

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.4 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2020-5218: 0.60% estimated exploitation activity in the next 30 days; percentile 48.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact This vulnerability gives the ability to switch channels via the channelcode GET parameter in production environments. This was meant to be enabled only when %kernel.debug% is set to true. However, if no syliuschannel.debug is set explicitly in the configuration, the default value which is %kernel.debug% will be not resolved and cast to boolean, enabling this debug feature even if that parameter is set to false. Patches Patch has been provided for Sylius 1.3.x and newer - 1.3.16, 1.4.12, 1.5.9, 1.6.5. Versions older than 1.3 are not covered by our security support anymore. Workarounds Unsupported versions could be patched by adding the following configuration to run in production:

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-prg5-hg25-8grq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-5218

Advisory: Ability to switch channels via GET parameter enabled in production environments
IDs: CVE-2020-5218, GHSA-prg5-hg25-8grq
Record: https://patchnext.com/advisories/cve-2020-5218 (revision 1, source checked 26 Oct 2026, 13:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: sylius/sylius 1.6.5, 1.5.9, 1.4.12, 1.3.16. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist sylius/sylius: affected < 1.3.16; >= 1.4.0, < 1.4.12; >= 1.5, < 1.5.9; >= 1.6.0, < 1.6.5; fixed in 1.6.5, 1.5.9, 1.3.16, 1.4.12

## Suggested inspection (read-only)
- Packagist sylius/sylius: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sylius/sylius.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-prg5-hg25-8grq (GitHub-reviewed advisory GHSA-prg5-hg25-8grq lists affected ranges: Packagist sylius/sylius >=0 =1.4.0 =1.5 =1.6.0 <1.6.5)

Commands are suggestions: review each one before running it.

Loading voting…