Directive injection when using dynamic overrides with user input
CVE-2020-5217GHSA-xq52-rv6w-397c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (secure_headers 6.2.0, 5.1.0, 3.8.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems secure_headers
- Affected
- >= 6.0.0, < 6.2.0>= 5.0.0, < 5.1.0< 3.8.0
- Fixed in
- 5.1.0, 3.8.0, 6.2.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xq52-rv6w-397c lists affected ranges: RubyGems secure_headers >=6.0.0 =5.0.0 =0 <3.8.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.4 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2020-5217: 1.83% estimated exploitation activity in the next 30 days; percentile 78.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact If user-supplied input was passed into append/overridecontentsecuritypolicydirectives, a semicolon could be injected leading to directive injection. This could be used to e.g. override a script-src directive. Duplicate directives are ignored and the first one wins. The directives in secureheaders are sorted alphabetically so they pretty much all come before script-src. A previously undefined directive would receive a value even if SecureHeaders::OPTOUT was supplied. The fixed versions will silently convert the semicolons to spaces and emit a deprecation warning when this happens. This will result in innocuous browser console messages if being exploited/accidentally used. In future releases, we will raise application errors resulting in 500s. Duplicate script-src directives detected. All but the first instance will be ignored. See https://www.w3.org/TR/CSP3/#parse-serialized-policy Note: In this case, the user agent SHOULD notify developers that a duplicate directive was…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-xq52-rv6w-397c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-5217 Advisory: Directive injection when using dynamic overrides with user input IDs: CVE-2020-5217, GHSA-xq52-rv6w-397c Record: https://patchnext.com/advisories/cve-2020-5217 (revision 1, source checked 26 Oct 2026, 15:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: secure_headers 6.2.0, 5.1.0, 3.8.0. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems secure_headers: affected >= 6.0.0, < 6.2.0; >= 5.0.0, < 5.1.0; < 3.8.0; fixed in 5.1.0, 3.8.0, 6.2.0 ## Suggested inspection (read-only) - RubyGems secure_headers: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on secure_headers. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xq52-rv6w-397c (GitHub-reviewed advisory GHSA-xq52-rv6w-397c lists affected ranges: RubyGems secure_headers >=6.0.0 =5.0.0 =0 <3.8.0) Commands are suggestions: review each one before running it.
Loading voting…