Skip to content

← Actionable
High, CVSS 7.3

Cross-site Scripting in Sanitize

CVE-2020-4054GHSA-p4x4-rw2p-8j8m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (sanitize 5.2.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems sanitize

    Affected
    >= 3.0.0, < 5.2.1
    Fixed in
    5.2.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
EPSS
  • CVE-2020-4054: 1.92% estimated exploitation activity in the next 30 days; percentile 79.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

When HTML is sanitized using Sanitize's "relaxed" config or a custom config that allows certain elements, some content in a <math or <svg element may not be sanitized correctly even if math and svg are not in the allowlist. You are likely to be vulnerable to this issue if you use Sanitize's relaxed config or a custom config that allows one or more of the following HTML elements: - iframe - math - noembed - noframes - noscript - plaintext - script - style - svg - xmp Impact Using carefully crafted input, an attacker may be able to sneak arbitrary HTML through Sanitize, potentially resulting in XSS (cross-site scripting) or other undesired behavior when that HTML is rendered in a browser. Releases This problem has been fixed in Sanitize 5.2.1. Workarounds If upgrading is not possible, a workaround is to override the default value of Sanitize's :removecontents config option with the following value, which ensures that the contents of math and svg elements (among others) are removed…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-p4x4-rw2p-8j8m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-4054

Advisory: Cross-site Scripting in Sanitize
IDs: CVE-2020-4054, GHSA-p4x4-rw2p-8j8m
Record: https://patchnext.com/advisories/cve-2020-4054 (revision 1, source checked 26 Oct 2026, 15:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: sanitize 5.2.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems sanitize: affected >= 3.0.0, < 5.2.1; fixed in 5.2.1

## Suggested inspection (read-only)
- RubyGems sanitize: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sanitize.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-p4x4-rw2p-8j8m (GitHub-reviewed advisory GHSA-p4x4-rw2p-8j8m lists affected ranges: RubyGems sanitize >=3.0.0 <5.2.1)

Commands are suggestions: review each one before running it.

Loading voting…