Information disclosure in SSB-DB
CVE-2020-4045GHSA-mpgr-2cx9-327h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ssb-db 20.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm ssb-db
- Affected
- >= 20.0.0, <= 20.0.0
- Fixed in
- 20.0.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mpgr-2cx9-327h lists affected ranges: npm ssb-db >=20.0.0 <20.0.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mpgr-2cx9-327h lists affected ranges: npm ssb-db >=20.0.0 <=20.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2020-4045: 1.28% estimated exploitation activity in the next 30 days; percentile 70.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact What kind of vulnerability is it? Who is impacted? Servers running SSB-DB 20.0.0 (which is packaged with SSB-Server 16.0.0) must upgrade immediately. There is no evidence that other SSB apps are vulnerable or that this problem has been exploited in the wild. The get() method is supposed to only decrypt messages when you explicitly ask it to, but there's a bug where it's decrypting any message that it can. This means that it's returning the decrypted content of private messages, which a malicious peer could use to get access to private data. This only affects peers running SSB-DB@20.0.0 who also have private messages, and is only known to be exploitable if you're also running SSB-OOO (default in SSB-Server), which exposes a thin wrapper around get() to anonymous peers. Patches Has the problem been patched? What versions should users upgrade to? Yes, please upgrade to SSB-DB 20.0.1 (or SSB-Server 16.0.1) immediately. Workarounds Is there a way for users to fix or remediate the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-mpgr-2cx9-327h
- Revision 1 · created ·
Published from osv record GHSA-mpgr-2cx9-327h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-4045 Advisory: Information disclosure in SSB-DB IDs: CVE-2020-4045, GHSA-mpgr-2cx9-327h Record: https://patchnext.com/advisories/cve-2020-4045 (revision 2, source checked 26 Oct 2026, 12:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ssb-db 20.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm ssb-db: affected >= 20.0.0, <= 20.0.0; fixed in 20.0.1 ## Suggested inspection (read-only) - `npm ls ssb-db --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ssb-db. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mpgr-2cx9-327h (OSV record GHSA-mpgr-2cx9-327h lists affected ranges: npm ssb-db >=20.0.0 <20.0.1 (fixed)) - Verified: https://github.com/advisories/GHSA-mpgr-2cx9-327h (GitHub-reviewed advisory GHSA-mpgr-2cx9-327h lists affected ranges: npm ssb-db >=20.0.0 <=20.0.0) Commands are suggestions: review each one before running it.
Loading voting…