Skip to content

← Actionable
High, CVSS 8.6

CSRF issue on preview pages in Bolt CMS

CVE-2020-4040GHSA-2q66-6cc3-6xm8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (bolt/bolt 3.7.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist bolt/bolt

    Affected
    < 3.7.1
    Fixed in
    3.7.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
EPSS
  • CVE-2020-4040: 1.77% estimated exploitation activity in the next 30 days; percentile 78.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Bolt CMS lacked CSRF protection in the preview generating endpoint. Previews are intended to be generated by the admins, developers, chief-editors, and editors, who are authorized to create content in the application. But due to lack of proper CSRF protection, unauthorized users could generate a preview. Patches This has been fixed in Bolt 3.7.1 References Related issue: https://github.com/bolt/bolt/pull/7853

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-2q66-6cc3-6xm8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-4040

Advisory: CSRF issue on preview pages in Bolt CMS
IDs: CVE-2020-4040, GHSA-2q66-6cc3-6xm8
Record: https://patchnext.com/advisories/cve-2020-4040 (revision 1, source checked 26 Oct 2026, 14:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: bolt/bolt 3.7.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist bolt/bolt: affected < 3.7.1; fixed in 3.7.1

## Suggested inspection (read-only)
- Packagist bolt/bolt: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on bolt/bolt.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2q66-6cc3-6xm8 (GitHub-reviewed advisory GHSA-2q66-6cc3-6xm8 lists affected ranges: Packagist bolt/bolt >=0 <3.7.1)

Commands are suggestions: review each one before running it.

Loading voting…