Reflected XSS in GraphQL Playground
CVE-2020-4038GHSA-4852-vrh7-28rf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (graphql-playground-html 1.6.22), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.6.22
- Fixed in
- 1.6.22
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4852-vrh7-28rf lists affected ranges: npm graphql-playground-html >=0 <1.6.22 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4852-vrh7-28rf lists affected ranges: npm graphql-playground-html >=0 <1.6.22
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:H/A:N
- EPSS
- CVE-2020-4038: 7.24% estimated exploitation activity in the next 30 days; percentile 94.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact directly impacted: - graphql-playground-html@<1.6.22 - all unsanitized user input for renderPlaygroundPage() all of our consuming packages of graphql-playground-html are impacted: - graphql-playground-middleware-express@<1.7.16 - unsanitized user input to expressPlayground() - graphql-playground-middleware-koa@<1.6.15 - unsanitized user input to koaPlayground() - graphql-playground-middleware-lambda@<1.7.17 - unsanitized user input to lambdaPlayground() - graphql-playground-middleware-hapi@<1.6.13 - unsanitized user input to hapiPlayground() as well as any other packages that use these methods with unsanitized user input. not impacted: - graphql-playground-electron - uses renderPlaygroundPage() statically for a webpack build for electron bundle, no dynamic user input - graphql-playground-react - usage of the component directly in a react application does not expose reflected XSS vulnerabilities. only the demo in public/ contains the vulnerability, because it uses an old…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-4852-vrh7-28rf
- Revision 1 · created ·
Published from osv record GHSA-4852-vrh7-28rf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-4038 Advisory: Reflected XSS in GraphQL Playground IDs: CVE-2020-4038, GHSA-4852-vrh7-28rf Record: https://patchnext.com/advisories/cve-2020-4038 (revision 2, source checked 26 Oct 2026, 12:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: graphql-playground-html 1.6.22. A vendor fix does not mean a deployment is fixed. ## Affected components - npm graphql-playground-html: affected < 1.6.22; fixed in 1.6.22 ## Suggested inspection (read-only) - `npm ls graphql-playground-html --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on graphql-playground-html. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4852-vrh7-28rf (OSV record GHSA-4852-vrh7-28rf lists affected ranges: npm graphql-playground-html >=0 <1.6.22 (fixed)) - Verified: https://github.com/advisories/GHSA-4852-vrh7-28rf (GitHub-reviewed advisory GHSA-4852-vrh7-28rf lists affected ranges: npm graphql-playground-html >=0 <1.6.22) Commands are suggestions: review each one before running it.
Loading voting…