Skip to content

← Actionable
Medium, CVSS 4.3

Ed25519 Signature Malleability in ed25519-java Due to Missing Scalar Range Check

CVE-2020-36843GHSA-p53j-g8pw-4w5f

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven net.i2p.crypto:eddsa

    Affected
    <= 0.3.0
    Fixed in
    no fixed version recorded
  • Maven net.i2p:i2p

    Affected
    < 0.9.39
    Fixed in
    0.9.39

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:N
EPSS
  • CVE-2020-36843: 0.14% estimated exploitation activity in the next 30 days; percentile 3.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The implementation of EdDSA in EdDSA-Java (aka ed25519-java) through 0.3.0 exhibits signature malleability and does not satisfy the SUF-CMA (Strong Existential Unforgeability under Chosen Message Attacks) property. This allows attackers to create new valid signatures different from previous signatures for a known message.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-p53j-g8pw-4w5f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-36843

Advisory: Ed25519 Signature Malleability in ed25519-java Due to Missing Scalar Range Check
IDs: CVE-2020-36843, GHSA-p53j-g8pw-4w5f
Record: https://patchnext.com/advisories/cve-2020-36843 (revision 1, source checked 26 Oct 2026, 16:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: net.i2p:i2p 0.9.39. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven net.i2p.crypto:eddsa: affected <= 0.3.0
- Maven net.i2p:i2p: affected < 0.9.39; fixed in 0.9.39

## Suggested inspection (read-only)
- Maven net.i2p.crypto:eddsa: check the installed version with your package manager.
- Maven net.i2p:i2p: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on net.i2p.crypto:eddsa, net.i2p:i2p.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-p53j-g8pw-4w5f (GitHub-reviewed advisory GHSA-p53j-g8pw-4w5f lists affected ranges: Maven net.i2p.crypto:eddsa >=0 =0 <0.9.39)

Commands are suggestions: review each one before running it.

Loading voting…