Skip to content

← Actionable
High, CVSS 7.5amended

Path Traversal in web-node-server

CVE-2020-36651GHSA-3fwq-qv5v-2wxf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (web-node-server 0.0.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2020-36651: 0.92% estimated exploitation activity in the next 30 days; percentile 60.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A vulnerability has been found in youngerheart nodeserver and classified as critical. Affected by this vulnerability is an unknown functionality of the file nodeserver.js. The manipulation leads to path traversal. The name of the patch is c4c0f0138ab5afbac58e03915d446680421bde28. It is recommended to apply a patch to fix this issue. The identifier VDB-218461 was assigned to this vulnerability.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-3fwq-qv5v-2wxf

  2. Revision 1 · created ·

    Published from osv record GHSA-3fwq-qv5v-2wxf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-36651

Advisory: Path Traversal in web-node-server
IDs: CVE-2020-36651, GHSA-3fwq-qv5v-2wxf
Record: https://patchnext.com/advisories/cve-2020-36651 (revision 2, source checked 26 Oct 2026, 12:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: web-node-server 0.0.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm web-node-server: affected < 0.0.11; fixed in 0.0.11

## Suggested inspection (read-only)
- `npm ls web-node-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on web-node-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3fwq-qv5v-2wxf (OSV record GHSA-3fwq-qv5v-2wxf lists affected ranges: npm web-node-server >=0 <0.0.11 (fixed))
- Verified: https://github.com/advisories/GHSA-3fwq-qv5v-2wxf (GitHub-reviewed advisory GHSA-3fwq-qv5v-2wxf lists affected ranges: npm web-node-server >=0 <0.0.11)

Commands are suggestions: review each one before running it.

Loading voting…