gry vulnerable to Command Injection
CVE-2020-36650GHSA-w5mw-f2hq-5fw8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (gry 6.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm gry
- Affected
- < 6.0.0
- Fixed in
- 6.0.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w5mw-f2hq-5fw8 lists affected ranges: npm gry >=0 <6.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w5mw-f2hq-5fw8 lists affected ranges: npm gry >=0 <6.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.0 · CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2020-36650: 2.19% estimated exploitation activity in the next 30 days; percentile 82.42 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability, which was classified as critical, was found in IonicaBizau node-gry up to 5.x. This affects an unknown part. The manipulation leads to command injection. Upgrading to version 6.0.0 is able to address this issue. The name of the patch is 5108446c1e23960d65e8b973f1d9486f9f9dbd6c. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-218019.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-w5mw-f2hq-5fw8
- Revision 1 · created ·
Published from osv record GHSA-w5mw-f2hq-5fw8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-36650 Advisory: gry vulnerable to Command Injection IDs: CVE-2020-36650, GHSA-w5mw-f2hq-5fw8 Record: https://patchnext.com/advisories/cve-2020-36650 (revision 2, source checked 26 Oct 2026, 12:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: gry 6.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm gry: affected < 6.0.0; fixed in 6.0.0 ## Suggested inspection (read-only) - `npm ls gry --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on gry. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-w5mw-f2hq-5fw8 (OSV record GHSA-w5mw-f2hq-5fw8 lists affected ranges: npm gry >=0 <6.0.0 (fixed)) - Verified: https://github.com/advisories/GHSA-w5mw-f2hq-5fw8 (GitHub-reviewed advisory GHSA-w5mw-f2hq-5fw8 lists affected ranges: npm gry >=0 <6.0.0) Commands are suggestions: review each one before running it.
Loading voting…