Skip to content

← Actionable
Critical, CVSS 9.8amended

flat vulnerable to Prototype Pollution

CVE-2020-36632GHSA-2j2x-2gpw-g8fm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flat 5.0.1, 4.0.2, 3.0.1, 2.0.2, 1.6.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm flat

    Affected
    < 1.6.2>= 2.0.0, < 2.0.2>= 3.0.0, <= 3.0.0>= 4.0.0, < 4.0.2>= 5.0.0, <= 5.0.0
    Fixed in
    4.0.2, 3.0.1, 5.0.1, 2.0.2, 1.6.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2020-36632: 1.21% estimated exploitation activity in the next 30 days; percentile 68.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

flat helps flatten/unflatten nested Javascript objects. A vulnerability, which was classified as critical, was found in hughsk flat up to 5.0.0. This affects the function unflatten of the file index.js. The manipulation leads to improperly controlled modification of object prototype attributes ('prototype pollution'). It is possible to initiate the attack remotely. Upgrading to version 5.0.1 can address this issue. The name of the patch is 20ef0ef55dfa028caddaedbcb33efbdb04d18e13. It is recommended to upgrade the affected component. The identifier VDB-216777 was assigned to this vulnerability.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-2j2x-2gpw-g8fm

  2. Revision 1 · created ·

    Published from osv record GHSA-2j2x-2gpw-g8fm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-36632

Advisory: flat vulnerable to Prototype Pollution
IDs: CVE-2020-36632, GHSA-2j2x-2gpw-g8fm
Record: https://patchnext.com/advisories/cve-2020-36632 (revision 2, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flat 5.0.1, 4.0.2, 3.0.1, 2.0.2, 1.6.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm flat: affected < 1.6.2; >= 2.0.0, < 2.0.2; >= 3.0.0, <= 3.0.0; >= 4.0.0, < 4.0.2; >= 5.0.0, <= 5.0.0; fixed in 4.0.2, 3.0.1, 5.0.1, 2.0.2, 1.6.2

## Suggested inspection (read-only)
- `npm ls flat --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flat.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2j2x-2gpw-g8fm (OSV record GHSA-2j2x-2gpw-g8fm lists affected ranges: npm flat >=0 =2.0.0 =3.0.0 =4.0.0 =5.0.0 <5.0.1 (fixed))
- Verified: https://github.com/advisories/GHSA-2j2x-2gpw-g8fm (GitHub-reviewed advisory GHSA-2j2x-2gpw-g8fm lists affected ranges: npm flat >=0 =2.0.0 =3.0.0 =4.0.0 =5.0.0 <=5.0.0)

Commands are suggestions: review each one before running it.

Loading voting…