Skip to content

← Actionable
Critical, CVSS 9.8amended

FurqanSoftware/node-whois vulnerable to Prototype Pollution

CVE-2020-36618GHSA-97jv-c342-5xhc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (whois 2.13.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm whois

    Affected
    < 2.13.6
    Fixed in
    2.13.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2020-36618: 1.01% estimated exploitation activity in the next 30 days; percentile 63.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A vulnerability classified as critical has been found in Furqan node-whois. Affected is an unknown function of the file index.coffee. The manipulation leads to improperly controlled modification of object prototype attributes ('prototype pollution'). It is possible to launch the attack remotely. The name of the patch is 46ccc2aee8d063c7b6b4dee2c2834113b7286076. It is recommended to apply a patch to fix this issue. The identifier of this vulnerability is VDB-216252.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-97jv-c342-5xhc

  2. Revision 1 · created ·

    Published from osv record GHSA-97jv-c342-5xhc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-36618

Advisory: FurqanSoftware/node-whois vulnerable to Prototype Pollution
IDs: CVE-2020-36618, GHSA-97jv-c342-5xhc
Record: https://patchnext.com/advisories/cve-2020-36618 (revision 2, source checked 26 Oct 2026, 12:17 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: whois 2.13.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm whois: affected < 2.13.6; fixed in 2.13.6

## Suggested inspection (read-only)
- `npm ls whois --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on whois.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-97jv-c342-5xhc (OSV record GHSA-97jv-c342-5xhc lists affected ranges: npm whois >=0 <2.13.6 (fixed))
- Verified: https://github.com/advisories/GHSA-97jv-c342-5xhc (GitHub-reviewed advisory GHSA-97jv-c342-5xhc lists affected ranges: npm whois >=0 <2.13.6)

Commands are suggestions: review each one before running it.

Loading voting…