Echo vulnerable to directory traversal
CVE-2020-36565GHSA-j453-hm5x-c46w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/labstack/echo/v4 4.2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/labstack/echo/v4
- Affected
- < 4.2.0
- Fixed in
- 4.2.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j453-hm5x-c46w lists affected ranges: Go github.com/labstack/echo/v4 >=0 <4.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2020-36565: 1.41% estimated exploitation activity in the next 30 days; percentile 72.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Due to improper sanitization of user input on Windows, the static file handler allows for directory traversal, allowing an attacker to read files outside of the target directory that the server has permission to read.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-j453-hm5x-c46w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-36565 Advisory: Echo vulnerable to directory traversal IDs: CVE-2020-36565, GHSA-j453-hm5x-c46w Record: https://patchnext.com/advisories/cve-2020-36565 (revision 1, source checked 26 Oct 2026, 14:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/labstack/echo/v4 4.2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/labstack/echo/v4: affected < 4.2.0; fixed in 4.2.0 ## Suggested inspection (read-only) - Go github.com/labstack/echo/v4: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/labstack/echo/v4. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-j453-hm5x-c46w (GitHub-reviewed advisory GHSA-j453-hm5x-c46w lists affected ranges: Go github.com/labstack/echo/v4 >=0 <4.2.0) Commands are suggestions: review each one before running it.
Loading voting…