Skip to content

← Actionable
High, CVSS 8.1

Data race in tiny_future

CVE-2020-36438GHSA-fg42-vwxx-xx5j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tiny_future 0.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2020-36438: 0.77% estimated exploitation activity in the next 30 days; percentile 55.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

tinyfuture contains a light-weight implementation of Futures. The Future type it has lacked bound on its Send and Sync traits. This allows for a bug where non-thread safe types such as Cell can be used in Futures and cause data races in concurrent programs. The flaw was corrected in commit c791919 by adding trait bounds to Future's Send and Sync.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-fg42-vwxx-xx5j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-36438

Advisory: Data race in tiny_future
IDs: CVE-2020-36438, GHSA-fg42-vwxx-xx5j
Record: https://patchnext.com/advisories/cve-2020-36438 (revision 1, source checked 26 Oct 2026, 15:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tiny_future 0.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io tiny_future: affected < 0.4.0; fixed in 0.4.0

## Suggested inspection (read-only)
- crates.io tiny_future: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tiny_future.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-fg42-vwxx-xx5j (GitHub-reviewed advisory GHSA-fg42-vwxx-xx5j lists affected ranges: crates.io tiny_future >=0 <0.4.0)

Commands are suggestions: review each one before running it.

Loading voting…