Object injection in PHPMailer/PHPMailer
CVE-2020-36326GHSA-m298-fh5c-jc66
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpmailer/phpmailer 6.4.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist phpmailer/phpmailer
- Affected
- >= 6.1.8, < 6.4.1
- Fixed in
- 6.4.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m298-fh5c-jc66 lists affected ranges: Packagist phpmailer/phpmailer >=6.1.8 <6.4.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2020-36326: 3.09% estimated exploitation activity in the next 30 days; percentile 87.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact This is a reintroduction of an earlier issue (CVE-2018-19296) by an unrelated bug fix in PHPMailer 6.1.8. An external file may be unexpectedly executable if it is used as a path to an attachment file via PHP's support for .phar files. Exploitation requires that an attacker is able to provide an unfiltered path to a file to attach, or to trick calling code into generating one. See this article for more info. Patches This issue was patched in the PHPMailer 6.4.1 release. This release also implements stricter filtering for attachment paths; paths that look like any kind of URL are rejected. Workarounds Validate paths to loaded files using the same pattern as used in isPermittedPath() before using them in any PHP file function, such as fileexists. This method can't be used directly because it is protected, but you can implement the same thing in calling code. Note that this should be applied to all user-supplied paths passed into such functions; it's not a problem specific to…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-m298-fh5c-jc66
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-36326 Advisory: Object injection in PHPMailer/PHPMailer IDs: CVE-2020-36326, GHSA-m298-fh5c-jc66 Record: https://patchnext.com/advisories/cve-2020-36326 (revision 1, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: phpmailer/phpmailer 6.4.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist phpmailer/phpmailer: affected >= 6.1.8, < 6.4.1; fixed in 6.4.1 ## Suggested inspection (read-only) - Packagist phpmailer/phpmailer: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on phpmailer/phpmailer. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-m298-fh5c-jc66 (GitHub-reviewed advisory GHSA-m298-fh5c-jc66 lists affected ranges: Packagist phpmailer/phpmailer >=6.1.8 <6.4.1) Commands are suggestions: review each one before running it.
Loading voting…